Beijer Electronics (formerly QSI Corporation)

Manufacturer of Mobile Data and Human Machine Interface Terminals.
It is currently Sun Nov 19, 2017 1:44 am

All times are UTC - 7 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Thu Jul 17, 2014 12:38 pm 
Offline

Joined: Tue Mar 18, 2014 9:07 am
Posts: 6
Hello,

I have some custom software that I frequently need to update/test on a G-72 terminal. In the past I have connected through a powered serial port and updated that way. (Boot into the boot menu, select download mode, save & exit, then download from Qlarity or the Downloader). I have been trying to find a more efficient way to do this and found that using the ethernet port works very well. The problem is that if the terminal is still connected to the Galil controller through serial, when I try to update via ethernet it never works. The downloader on the computer side gives a progress bar like it's updating, but it disappears before finishing and if you try again it says to connect a terminal to the ethernet. The terminal will just sit and wait to receive a program. This works fine if powered through the serial port, but not communicating to the galil. Is there anyway I can get this to work? Maybe disable the serial ports until finished?


Top
 Profile  
 
PostPosted: Thu Jul 17, 2014 12:51 pm 
Offline
QSI Support
QSI Support
User avatar

Joined: Wed Mar 08, 2006 12:25 pm
Posts: 881
Location: Salt Lake City, Utah
A few thoughts:
  • Consider putting your unit into Development mode instead of Download mode (Power On Setup->Flash Memory->App Mode. This will allow the unit to download a new application each time power is cycled. This is more efficient than using the menu system when you are in development. Change back to Download mode once you have a version of the application you want to live with for a while.
  • Try disabling serial port feedback: Power On Setup->Feedback->Serial: No. My guess is this is what is giving you grief. The unit is trying to transmit a message on the serial port indicating that it is ready to receive an application. However the Galil is holding deasserting the serial handshake line preventing the G72 from sending that message
  • As an alternative you could disable RTS/CTS flow control on COM1 (assuming you have it enabled)
  • Do not try to download while you are in Power On Setup. There was an issue with some versions of firmware which permitted a download to progress while in Power On Setup, but not ever be fully accepted by the unit. If you use development mode this should not be an issue

_________________
Jeremy
http://www.beijerinc.com


Top
 Profile  
 
PostPosted: Thu Jul 17, 2014 3:02 pm 
Offline

Joined: Tue Mar 18, 2014 9:07 am
Posts: 6
For disabling serial feedback, can that be done in software?


Top
 Profile  
 
PostPosted: Fri Jul 18, 2014 5:06 am 
Offline
QSI Support
QSI Support
User avatar

Joined: Wed Mar 08, 2006 12:25 pm
Posts: 881
Location: Salt Lake City, Utah
Yes. Use SetSystemSetting, look for an option called SYS_FEEDBACK and read the documentation on it.

_________________
Jeremy
http://www.beijerinc.com


Top
 Profile  
 
PostPosted: Fri Jul 18, 2014 6:34 am 
Offline
QSI Support
QSI Support
User avatar

Joined: Wed Mar 08, 2006 12:25 pm
Posts: 881
Location: Salt Lake City, Utah
Here is how I might tackle this in my code:
Code:
func Startup ()
    handles MSG_INIT

    dim fb as syscmd_feedback
    GetSystemSetting (SYS_FEEDBACK_TYPE, fb, SYSREAD_SAVED)

    if (fb or FBTYPE_SERIAL) <> 0xFFFF then
        fb = fb and FBTYPE_SERIAL
        SetSystemSetting(SYS_FEEDBACK_TYPE, fb, SYSACT_ALWAYS)
        SetSystemSetting(SYS_SAVE, false, SYSACT_ALWAYS)
    endif

    return
endfunc


_________________
Jeremy
http://www.beijerinc.com


Top
 Profile  
 
PostPosted: Wed Jul 23, 2014 11:24 am 
Offline

Joined: Tue Mar 18, 2014 9:07 am
Posts: 6
So this seems to work for getting from the running application to the download just fine, however i'm having some other issues now I'm not sure are related. After I uploaded code from ethernet, the program seems to run fine, communicate over the serial to the Galil just fine for sending commands.

But when I try to set variables on the Galil I keep getting the response "Unexpected controller response" What's even more odd is that this happens consistently on some systems, and does NOT happen ever on others they are both running the same software on both the G-72 and the Galil. I can tell you that the error is coming through in the GalilCommV2 object in the Private function Parse.


Top
 Profile  
 
PostPosted: Wed Jul 23, 2014 12:38 pm 
Offline
QSI Support
QSI Support
User avatar

Joined: Wed Mar 08, 2006 12:25 pm
Posts: 881
Location: Salt Lake City, Utah
Try setting the unsolicitedAware property of the GalilComm object to true.

Do you query any strings that might have a colon (:) or question mark (?) as part of the string?

_________________
Jeremy
http://www.beijerinc.com


Top
 Profile  
 
PostPosted: Wed Jul 23, 2014 1:30 pm 
Offline

Joined: Tue Mar 18, 2014 9:07 am
Posts: 6
There shouldn't be any : or ? in the queries and I am trying to avoid sending any unsolicited messages. I set the Galil port that sends unsolicited messages to the ethernet port just to make sure, but still getting this error.

I've been digging around some and it seems to be a wiring issue or a setting on Galil I am just not aware of. I can avoid this error by bypassing some wiring, so I am looking into what may be the issue there.

Thanks for the response, I'll update if I can't find anything wrong with the wiring.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 7 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group