Beijer Electronics (formerly QSI Corporation)

Manufacturer of Mobile Data and Human Machine Interface Terminals.
It is currently Tue Nov 21, 2017 8:37 pm

All times are UTC - 7 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Wed Jun 15, 2011 4:11 pm 
Offline
User avatar

Joined: Wed Feb 02, 2011 9:20 am
Posts: 20
I have looked at some of the other similar post in the support forum but they do not seem to be quite the same as the problems I am having.

I am getting the "NetOpen: No Free Transmission Channel (#161)" error and green screen. I am using MBComV2 and communicating with MB_TCP. I originally thought I was getting this error due to the fact that I was not communicating with all of the Modbus slaves, but I changed the "connectatstart" property to false for the objects that do not have anything to communicate with, and still got the error. I have used similar programming on a G75 terminal and never got this error. I am using an A12 running QlarityCE and Qlarity Foundry 2.63.


Top
 Profile  
 
PostPosted: Thu Jun 16, 2011 6:40 am 
Offline
QSI Support
QSI Support
User avatar

Joined: Wed Mar 08, 2006 12:25 pm
Posts: 881
Location: Salt Lake City, Utah
I am not entirely sure what might be wrong, but if I had to take a guess, the error means that there is an issue with the Ethernet on the unit (for example it never got a DHCP network address, or the cable is unplugged).

Are you able to ping your A12?

_________________
Jeremy
http://www.beijerinc.com


Top
 Profile  
 
PostPosted: Thu Jun 16, 2011 7:22 am 
Offline
User avatar

Joined: Wed Feb 02, 2011 9:20 am
Posts: 20
I am able to ping my A12 and the Modbus communication through ethernet works fine. The error doesnt appear until 20 min or so after a boot up. I am using a static IP address and DHCP is disabled.


Top
 Profile  
 
PostPosted: Mon Jun 20, 2011 8:50 am 
Offline
User avatar

Joined: Thu Mar 02, 2006 2:12 pm
Posts: 487
Location: Salt Lake City, Utah
If you can e-mail a copy of the workspace, I'd like to see if I can reproduce the error.

_________________
Ron L.

http://www.beijerelectronicsinc.com/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 7 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group