Beijer Electronics (formerly QSI Corporation)

Manufacturer of Mobile Data and Human Machine Interface Terminals.
It is currently Fri Nov 24, 2017 12:15 am

All times are UTC - 7 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Opto 22 & Qlarity
PostPosted: Thu Feb 08, 2007 9:22 am 
Offline

Joined: Thu Feb 08, 2007 9:10 am
Posts: 2
Location: Denver
We currently use QTerm 75s & 70s running Qlarity as the HMI for an Opto22 control system at our training center. We are running Qlarity version 1.53 and firmware 1.530-c on the terminals.



As our control system has grown, we have been having a number of problems with the terminals crashing. We think it has to do with the Opto_ioControl.lib we use in Qlaity to communicate with the Opto PLCs. I was looking at upgrading to Qlarity 2.40 and the new firmware, but noticed there is a new Opto library (OptoUIO.qlib) which I do not have the file for.



My question is this, will Qlarity 2.40 and new firmware work with Opto? Was the Opto comm library rewritten (from Opto_ioControl.lib to OptoUIO.qlib) and possibly resolve some of our problems? How can I obtain the new Opto library? Lastly does anyone have general advice for Opto/Qlarity systems.



I appreciate any help with issue, and I apologize in advance if this question was misplaced.



Thank you,

Zak Allen


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 08, 2007 10:31 am 
Offline
QSI Support
QSI Support
User avatar

Joined: Wed Mar 08, 2006 12:25 pm
Posts: 881
Location: Salt Lake City, Utah
Quote:
My question is this, will Qlarity 2.40 and new firmware work with Opto? Was the Opto comm library rewritten (from Opto_ioControl.lib to OptoUIO.qlib) and possibly resolve some of our problems? How can I obtain the new Opto library? Lastly does anyone have general advice for Opto/Qlarity systems.




Qlarity 2.40 will work with Opto, as will the new firmware (which is required to use Qlarity Foundry 2.40). In fact, simply upgrading the firmware could resolve some of your problems, as the network stack had received significant work between versions 1.53 and 2.40.



Where did you get Qlarity Foundry 2.40? If you downloaded it from our web site, it will not include any of the Opto 22 tools you might need. If you got the Opto 22 version from the engineering section of our web site, that version was never fully released. (We are putting on the finishing touches to a fully released Opto 2.50 to be released in the next couple of weeks). I think that the test build I put up there may have been missing the OptoUIO.qlib library.



OptoUIO.qlib supercedes Opto_ioControl.lib for Opto controllers running R6 and R7 firmware versions, and provides substantial new functionality, but is not backwards compatible. (i.e. you cannot simply add OptoUIO.qlib to your existing workspace and expect it to use it. You have to design a new workspace to use the OptoUIO.qlib library). The older library is still supported, and I would be interested to hear of any specific problems that you are experiencing. Especially after you migrate to firmware version 2.40 or newer on your Qlarity terminal. (You can continue to use Qlarity Foundry 1.53 with terminals running 2.40 firmware). Be sure to include your the version of Qlarity Foundry, the Qlarity firmware version and the version of firmware in the Opto 22 controller in any reports.



I have moved this question to the software support forum where I think it is a better subject fit.

_________________
Jeremy
http://www.beijerinc.com


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 08, 2007 12:06 pm 
Offline

Joined: Thu Feb 08, 2007 9:10 am
Posts: 2
Location: Denver
Jeremy,

Thank you for the quick response and information. I look forward to the new version of Qlarity for Opto and as you mentioned, I assumed I would have to redesign our system (although I appreciate the warning).



I will try the new firmware and see if that helps with some of the issues. As for the problems we are having, I will post a better description as well as all our version and configuration data in the near future.



Thank you again for your time and support.

Zak Allen


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 7 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group