Beijer Electronics (formerly QSI Corporation)

Manufacturer of Mobile Data and Human Machine Interface Terminals.
It is currently Sun Nov 19, 2017 3:33 am

All times are UTC - 7 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Mar 06, 2009 2:07 pm 
Offline

Joined: Thu Jan 17, 2008 6:51 am
Posts: 37
Location: Detroit, MI
Recently upgraded to Foundry 2.60. Everything worked fine for a while, but two days ago, I tried to run the simulator connecting through my serial port, and I'm getting no response. The communications window shows my laptop sending data, but the destination hardware doesn't receive any messages. All of my settings are compatible and I'm at my wits end right now. Anyone have any thoughts?

_________________
---

Qlarity Foundry v2.5

BFF v1.023

Firmware v2.500


Top
 Profile  
 
PostPosted: Fri Mar 06, 2009 3:04 pm 
Offline
QSI Support
QSI Support
User avatar

Joined: Wed Mar 08, 2006 12:25 pm
Posts: 881
Location: Salt Lake City, Utah
If I understand the question correctly, you are saying that in SimulationView, Qlarity Foundry displays data in the Communication Window indicating that the simulated Qlarity device (G55/G58/G70/G75/Z60) is transmitting serial port data. However no data is actually being transmitted from your laptop's serial port.

The first thing I would check is that you have actually associated a simulated Qlarity serial port with a physical serial port on your laptop. (By default the ports are not associated). Select Tools->Settings->Simulation to set up that association.

_________________
Jeremy
http://www.beijerinc.com


Top
 Profile  
 
PostPosted: Fri Mar 06, 2009 3:14 pm 
Offline

Joined: Thu Jan 17, 2008 6:51 am
Posts: 37
Location: Detroit, MI
You understand perfectly...

The hardware association has been made, and all settings are compatible with the hardware. Drivers are updated, serial port is assigned to COM1 in the BIOS, and the software communicates fine when installed on the G55...I've no idea on what's actually happening or how to fix it.

_________________
---

Qlarity Foundry v2.5

BFF v1.023

Firmware v2.500


Top
 Profile  
 
PostPosted: Fri Mar 06, 2009 3:20 pm 
Offline
QSI Support
QSI Support
User avatar

Joined: Wed Mar 08, 2006 12:25 pm
Posts: 881
Location: Salt Lake City, Utah
Presumably you are communicating from the G55 to some device. Are you attaching the same cable to your G55 as you are to the DB9 connector on your PC? If so that could be the problem. You may need a null modem adapter on the cable when using your PC.

Another thing to check: Do you have other software on the laptop that you can use to successfully communicate with your device?

Can you successfully download an application to the G55 using the serial port?

_________________
Jeremy
http://www.beijerinc.com


Top
 Profile  
 
PostPosted: Mon Mar 09, 2009 6:06 am 
Offline

Joined: Thu Jan 17, 2008 6:51 am
Posts: 37
Location: Detroit, MI
I haven't ever used the serial port to download an application. My serial port and the cables/connectors I have do not provide power to the Q55.

I use a serial cable with a RS-232/RS-485 converter and another cable which I'm not sure of the name (KDV-X5 is on the connnections). I've tried different cables and modems to no avail.

I installed Qlarity 2.60 on another computer and used the same setup I've used before and it worked fine. My guess right now is that there's something wrong with my serial port on my computer.

_________________
---

Qlarity Foundry v2.5

BFF v1.023

Firmware v2.500


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 7 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group